BrowseFilesServerRequest

Mar 23, 2011 at 11:22 PM

Hi,

I have a webpage where I have the menu structure stored in XML. I'm using the typps editor for editing the html on each page in the structure.

Now I would like to use the html link function for inserting links, and I would like the editor to load my entire menu structure when browsing for files(could be in a treeview)

 

Is this possible to achieve?

 

Thanks

Patrik

Coordinator
Mar 24, 2011 at 9:23 AM

Hello Patrik, yes it's very much possible and it is supported out of the box. You'll have to retrieve and traverse your xml content building the TreeNodes in the file browser Treeview. We have added a new entry in the online documentation you can find at the following url :

http://docs.typps.com/2010/10/html-editor.html#onbrowsefiles

This should cover your current scenario. We have also added an online demo you can see at the following url :

http://demo.typps.com/Editor/filebrowser.aspx

Earlier today we have also commited an update that is not yet the official release but it's downloadable from source code. You are encouraged to use this release as it fixes a few bugs in ie9.

The release is availabe in changeset: http://typps.codeplex.com/SourceControl/changeset/changes/63057

Many thanks for asking about this as it prompted us to update the documentation and demo.

Best regards,

Alessandro

Mar 24, 2011 at 11:05 AM

Hi, thanks for this, it really helps a lot.

 

But I got a new issue with the latest version which you mentioned above. After updating to the new typps.dll, the files are not inserted into the editor. I'm able to load my file treeview correct, and it puts the value into the url textbox in the hyperlink information pop up. But while press ok for insert into editor, nothing happens. In previous version it worked fine.

I thought that it could be some problem with my treeview, but I have tried to just enter a normal URL without using browse button and still it's not working.

 

In the last version I had(i think it was 2.9) it inserted the links, but the text of the link looked strange ($temp$typps$anchor$href) and it change my "&" in the URL to "&" which destroyed the actual URL. It where similar to the old other problem you had with Imageupload, which you solved perfectly in some release a while ago.

Coordinator
Mar 24, 2011 at 11:10 AM
Edited Mar 24, 2011 at 11:11 AM

The current online demo uses the same version from the latest changeset. 

Can you test on that demo and let me know if you see the problem. Also let me know the steps you took to experience the problem, along with your browser type/version number.

Thanks for reporting,

Alessandro

Coordinator
Mar 24, 2011 at 11:14 AM

ahhh! I see now. We broke ie8 in the process. I will fix it now.

Thanks

Coordinator
Mar 24, 2011 at 11:29 AM

Ok, it's fixed now. I must ask you to download from the latest changeset again. I am currently uploading my changes. It will be up in a few minutes. Just keep checking here :

http://typps.codeplex.com/SourceControl/list/changesets

Many thanks for reporting this issue quickly.

Have a good day,

Alessandro

Mar 24, 2011 at 11:55 AM

Hi again, thanks for quick reply. I have made tests on different browsers, with you only demo, http://demo.typps.com/Editor/filebrowser.aspx

Steps

  • 1, Click on hyperlink button(create link) in editor
  • 2, Click browse button
  • 3, Select Basic.aspx, press OK
  • 4, Url in Textbox looks ok, press OK
  • 5, Click on hyperlink button(create link) in editor
  • 6, Click browse button
  • 7, Select Default.aspx, press OK
  • 8, Adds parameter to URL (?Test=Hello&ID=1"), press OK

 

Browsers

  • Google Chrome 10.0.648.151
    • Insert links works, but they are not correct(text is weird and querystring replaces "&" with "&", see below:
      <p>
              <a href="/Editor/basic.aspx">$temp$typps$anchor$href</a>
              <br />
            </p>
            <p>
              <br />
            </p>
            <p>
              <a href="/Editor/default.aspx?Test=Hello&#38;ID=1">$temp$typps$anchor$href</a>
              <br />
            </p>
  • Firefox 3.6.16
    • Insert links doesn't work at all, nothing happens
  • IE 7, 7.0.5730.11CO
    • Insert links doesn't work at all, nothing happens
Mar 24, 2011 at 12:19 PM

Sorry, I didn't see you latest posts. I will download and try again.

Thanks a lot

 

//Patrik

Mar 24, 2011 at 12:44 PM

Hi again,

 It's still not working properly for any of above browser

(and save in editmode in this thread doesn't work, that is why I create a new reply)

Does it work for you in above mentioned browsers?

Coordinator
Mar 24, 2011 at 1:00 PM

yes, works just fine here.

I have updated the online demo. does it happen there too?

http://demo.typps.com

Alessandro

Coordinator
Mar 24, 2011 at 1:23 PM
Edited Mar 24, 2011 at 1:26 PM

Also, regarding the ampersand being converted into the html entity &#38; (that's because ampersand needs to be escaped when the link is included in an html document). We use the number entity &#38  in place of ampersand but we could have very well used the named entity &amp; 

The choice to use the number entity over named entity is because our sgml parser uses number by default and it enjoys better browser support.

When your links are clicked they wont show the entity but rather simply & as you want it. You can test this in preview mode to verify.

Mar 24, 2011 at 2:03 PM

Hi, Thanks for explanation about the ampersand. I'm still trying on http://demo.typps.com/Editor/filebrowser.aspx

 

This is really strange, because it's still not working here, I also went to my MacBook and same thing there, nothing happens in Firefox. I also tried Safari and there I got same result as in Google Chrome, the link is created but the visible name of the link is: $temp$typps$anchor$href

 

Would it be possible to include following functionality in the future:

  • When selecting the URL, the textbox is filled with the URL, but maybe it could also be a good idea to let the user select their own name on the href
  • If you have a lot of files in the browse window, you will not see the buttons, maybe you could add some scroll functionality
Coordinator
Mar 24, 2011 at 2:36 PM
Edited Mar 24, 2011 at 2:37 PM

That's quite strange because I experience the opposite in that everything is working. I will double check and let you know. In the meantime make sure your cache is cleared. Since javascript is cached on the client, you could very well be still using the older version. 

As for the scrolling, I may have added the style to overflow by default, I'll check that too and in case it's not I'll either tell you how to set that yourself or make it a default.

We will consider your other request with regard on the ability to edit the innercontent of the anchor element through the hyperlink editor itself in the next release but this will take a while as we have to start working on that yet. Most likely work will start on that version in april.

Alessandro

Mar 24, 2011 at 3:23 PM

Hi, yes it's very strange. That was why I tried it on my Mac aswell, and on that machine I have never entered into any page where TYPPS is used. I will try to restart both the Mac and my developer computer and try again.

I will continue testing and developing against the editor and let you know if I find any other issues or good findings when it comes to functionality.

 

Many thanks once again for a really great tool

 

//Patrik

Coordinator
Mar 24, 2011 at 3:27 PM

I look forward to that. In the meantime I have tested on a secondary machine and it just works. If I find out what the problem is I'll let you know on this thread.

Thanks for reporting back.

Alessandro

Coordinator
Mar 25, 2011 at 7:28 AM

Hello, I have finally tracked the problem and fixed it. Apparently in the steps you described above, you never made a selection and proceeded to insert a link via the hyperlink editor. In all my tests I always made a selection first since this is the normal behavior I was expecting. 

We have now made the editor tolerant to  your situation as well. In case no selection is made then the anchor element inserted into the documet will contain the href value.

In a future release we will also support adding a caption through the hyperlink editor itself as you have requested in one of the posts above.

Many thanks for your patience. You may download the fixed version from the latest changeset. We have also updated the demo pages to the version in the latest changeset. You can test there before downloading.

Have a good day,

Alessandro.

Mar 25, 2011 at 7:39 PM
Hi, thanks for this, it works in FF now. What exactly to do mean by selecting a value? I really felt that I did it the correct way..
I opened the browser button and selected a link from the treeview and then pressed button "OK".. After that the url was present in the URL textbox and then I inserted the value into the editor...

Isn't usability underestimated:)

Another issue I found: Whenever I tries to create a child treenode to firstlevel treenode(the ones in your demo, basic.aspx,default.aspx) I get an Stackoverflowexception when the browse event has finalized, have you seen or experienced that? I could give some sample code to describe my problem..

Thanks
Patrik
Coordinator
Mar 25, 2011 at 8:19 PM

Indeed that was a bug and you did well.

I'll also look into the stackoverflow and let you know.

Thanks for reporting,

Alessandro

Coordinator
Mar 25, 2011 at 8:29 PM

Patrick, I just tried a very mild test and everything seems ok. If you can provide me with the piece of code that produced the stackoverflow so that i can repo it on my end,  it would be great.

Thanks,

Alessandro