Is the uploading function of Editor working well?

Nov 25, 2010 at 3:56 AM

Hello,

    I'm trying typps 2.8, and want to use its uploading function by "create link"->"browse"->"upload"

    I implemented a "FileUploaded" event handler, and find it's triggered after I selected a file and clicked "OK"

    But in the event handler, I found the content of the second parameter "Typps.UploadedFileEventArgs e" are all null, though "e" itself is not null.

    But I can get the file from "Request.Files".

    And, the function of "EmbeddedImagePicker.ImageUpload" works well for me.

    So I wonder is there anything wrong with the Editor's uploading function or I did anything wrong?

    Thanks & Regards!

    Liven

Coordinator
Nov 25, 2010 at 12:16 PM

Hello Liven, you are right. This is a bug and I have fixed it now. I will push the update tomorrow and let you know here when it's up.

Many thanks for reporting this.

Alessandro

Nov 25, 2010 at 3:35 PM

Thank you Alessandro, for your quick respond!

I'm glad its being fixed.

Coordinator
Nov 25, 2010 at 11:14 PM

Hello again, a new release (2.9) is up. This version fixes the bug you are currently seeing.

Have a good day,

Alessandro

Nov 26, 2010 at 1:51 AM

Hi Alessandro, I tried the new release, and found the file uploaded correctly, thanks!

However, I find the url box is not updated after the file uploaded. I don't know if there is anything I should do to make it happen.

I guess I should set the "e.ServerSideFilePath" but it didn't take effect. (And I didn't implement the "BrowseFilesServerRequest" for a reason)

BTW: Is there any more document or manual besides the two articles in the blog? I'm currently using Typps by guessing the functionalities from their names...

Sorry for bother you again, your efforts are very appreciated!

Coordinator
Nov 26, 2010 at 2:37 AM
Edited Nov 26, 2010 at 2:40 AM

whoops! In one of the ancient release I have done a pretty massive refactoring effort and the bugs you currently see are the aftermath i suppose. You have guessed right that you need to pass the new path to the serversidefilepath property.  I plan to update that single post in the documentation with more content. In the meantime if you have any trouble you may post it here.

I'm not too late to update the current release since your the only one that has downloaded it. In a minute, I shall re-up the same 2.9 release with the fix for the second bug.

Thank you for the quick report. You have saved me from making another release and it's absolutely no bother.

Alessandro

Coordinator
Nov 26, 2010 at 3:16 AM

Liven, ok, it's up. Try to redownload the same 2.9 release.

Alessandro

Nov 26, 2010 at 4:40 AM

Hi Alessandro,

I cannot see the new release from the download page.

It says "There is no recommended release. Please select a release from the "Releases" box to the right.". And there is no 2.9 either, in the box to the right.

Further more, the link in your prior reply is disabled.

Could you please check it? Thanks!

Coordinator
Nov 26, 2010 at 8:08 AM

fixed. I forgot to make the release public after the update apparently. 

Have a good day,

Alessandro

Nov 26, 2010 at 9:15 AM

It seems works!

Thank you soooo~ much Alessandro~

Coordinator
Nov 26, 2010 at 9:55 AM

cool. Thanks for reporting back.

Alessandro